Hyundai Veloster N Forum banner

21 - 36 of 36 Posts

·
Registered
Joined
·
44 Posts
I'm really experiencing the rough starts and awful driving behavior while cold. Had a super long rough start this morning with what sounded like some grinding. I only use 91 octane from chevron stations. Wondering if anyone has had any resolution with the dealer over this exceptionally common issue.
 

·
Registered
Joined
·
315 Posts
I believe people that have a good dealership relationship have had injectors replaced and the hard starts disappear. But it's hard to say if this is the cause for everyone. My dealership experience is not so great so I'm just recording my starts, will eventually pull the plugs and see what they look like, and if the hard starts ever increase in frequency I may approach them about it.

At this point they would not be able to replicate and I would end up leaving my car there for numerous test drives to not be able to sort out a starting problem that happens only a few times a month.
 

·
Registered
Joined
·
170 Posts
I havent. But I am dropping car tomorrow for them to check again. Along with my not starting and fuel smell now the exhaust has changed. Sounds like **** now. Anyway I hope they can find something. Also I am only getting around 170 miles out of a tank of gas. And that's driving normal.
 

·
Registered
Joined
·
315 Posts
Wow, ok definitely a problem if you're getting 13mpg with normal driving. I may hold off on the sxth dp I was about to order to see what you find.
 

·
Registered
Joined
·
170 Posts
Yea I hope they find something tom. It so crazy that it hasn't thrown an check engine light at all. I got Hyundai corporate involved cause I've been over there 3 or 4 times just to be shrugged off cause no engine light on. But there is def a problem
 

·
Registered
Joined
·
44 Posts
Yea I hope they find something tom. It so crazy that it hasn't thrown an check engine light at all. I got Hyundai corporate involved cause I've been over there 3 or 4 times just to be shrugged off cause no engine light on. But there is def a problem
Yea I hope they find something tom. It so crazy that it hasn't thrown an check engine light at all. I got Hyundai corporate involved cause I've been over there 3 or 4 times just to be shrugged off cause no engine light on. But there is def a problem
That's really disappointing. I had a similar experience. In fact, I called two days after dropping my car off and after being transferred 4 times only to be hung up on I was told they know nothing about my car being dropped off. They acted like they lost my car and had to go find it. I could not for the life of me get an answer whether I could get a loaner if they need my car longer. Eventually came down to just demand my car back and that's when the service manager sat down with me.
 

·
Registered
Joined
·
170 Posts
Oh yea I had to sit down with the owner cause last time I left it I put a dash cam in the car. When i picked it up i look and the service guy was dogging my car bad. so I turned him in. That's crazy. Anyway yea I'll update about what they say this time. The guy from corporate Hyundai told me that if there is no engine light or codes and they cant replicate it they wont fix it. Even with the videos I have. But it is doing it daily now so I know they will see it. And the exhaust issue. It's so quite now. And has no over run after u let of gas talkie it's supposed to. I really think mine is fuel injector or spark plug related
 

·
Registered
Joined
·
170 Posts
And what is even weirder is the dash claims I'm getting 22 25 mpg. But I watched the mileage and I filled up at 2200 miles. Then I had to fill up again at 2370. So the computer ain't right either.
 

·
Registered
Joined
·
119 Posts
The computer was never right in my GenCoupe when calculating overall MPG. I'm sure it's using an algorithm to calculate rates across trends to show a "more appropriate" MPG, but, I just want miles / gallons from the pump, please and thank you.
 

·
Registered
Joined
·
359 Posts
Oh yea I had to sit down with the owner cause last time I left it I put a dash cam in the car. When i picked it up i look and the service guy was dogging my car bad. so I turned him in. That's crazy. Anyway yea I'll update about what they say this time. The guy from corporate Hyundai told me that if there is no engine light or codes and they cant replicate it they wont fix it. Even with the videos I have. But it is doing it daily now so I know they will see it. And the exhaust issue. It's so quite now. And has no over run after u let of gas talkie it's supposed to. I really think mine is fuel injector or spark plug related
Did you contact hyundai assurance? From what i hear, they're really proactive at making sure dealers get things done. Kind of strange for corporate to not even help.
 

·
Registered
Joined
·
170 Posts
Well I sent emails of my videos of the problems to the open case thing off my Hyundai. And that's what they guy told me when he called. If they do nothing this time I'm gonna call the number inside the dealer for assurance i guess
 

·
Registered
Joined
·
170 Posts
I was willing to deal with the random not starting. But the gas mileage issue and. Ow the exhaust sounding terrible. They gonna do something lol. I'm sick of dealing with them honestly.
 

·
Registered
Joined
·
46 Posts
I bet you it's leaky injectors. Anyone experiencing rough starts and gas smell at start up has had these issues solved with getting new injectors and plugs, if they're fouled. It's in a couple of big threads on the other N forum.
 
21 - 36 of 36 Posts
Top