Hyundai Veloster N Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, new to this forums so hopefully I’m in the correct place. I have a Veloster N performance pack and was reading that the oem limiter it set to 21 psi for boost. However when looking at the boost gauge on the dash it only seems to go up to about 16. Not sure if this is supposed to be or not but a little back story on the concern I installed a BOV and it had a leak so I lost significant power but it displayed15 lbs of boost on the screen but after switching back to the oem recirculation valve it seems to have the power back but still is at about 15-16 lbs on the screen. Mainly wondering if all of them display at 15-16 or if I should be concerned. Any feedback is appreciated. Thanks in advance!
 

·
Registered
Joined
·
2,095 Posts
No, overboost is limited and capped to a max boost of 21 psi. The VN PP normally runs a 15-16 psi. There's nothing wrong with your VN. Use the search engine in the top right hand corner of the page to find a multitude of threads regarding the subject.
 

·
Registered
Joined
·
289 Posts
I was noticing today the boost gauge in the dash was going up to around 15 16. But when I was looking in the n menu on the touch screen the turbo graph it showed the highest at 9.3 psi. Is it that much off from the other gauge?
 

·
Registered
Joined
·
107 Posts
I have a noticeable variance in boost and torque between the dash menu and touch screen as well. Dash shows 275lb/ft torque and 15psi of boost but the touch screen will only show around 200lb/ft torque and 9psi boost. Not sure why there is a discrepancy, but the car is definitely making plenty of power.
 

·
Registered
Joined
·
289 Posts
I have a noticeable variance in boost and torque between the dash menu and touch screen as well. Dash shows 275lb/ft torque and 15psi of boost but the touch screen will only show around 200lb/ft torque and 9psi boost. Not sure why there is a discrepancy, but the car is definitely making plenty of power.
Oh yes. Definitely plenty of power. I just recently got over the break in period. And I had in n mode and shifted to second and hit it. **** that thing took the **** off. Lmaooo
 

·
Registered
Joined
·
126 Posts
Do I have a bad clutch or engine compression issues? I get 10 psi max and I have to smash that throttle
 

·
Registered
2019 Hyundai Veloster N Performance Blue Base
Joined
·
48 Posts
Do I have a bad clutch or engine compression issues? I get 10 psi max and I have to smash that throttle
That’s normal. They make it to where in order to max the psi in the turbo you have to put the pedal all the way down. Apparently it’s a way to simulate a more naturally aspirated feel
 

·
Registered
Joined
·
2,095 Posts
Do I have a bad clutch or engine compression issues? I get 10 psi max and I have to smash that throttle
No but you can check your compression and you'd know it if it was a bad clutch as you'd smell it. Personally, I wouldn't depend upon the OEM gauges to read accurately. Buy either a good boost gauge or OBD II data logger, then you'll see the accurate boost levels.:)(y)
 

·
Registered
Joined
·
2 Posts
Another possibility. Check to see if your waste gate solenoid motor is at 4 volts, pushed closed and not higher like 4.5 to 5.0 volts.Check it from the back of the connector with pins or the proper back connector jumper pin tool. Bring it in if you are a warranted car. Adjust tot back to 4.0 volts by adjusting the adjustable rod if you are are not a warranted car. Be forewarned you may show "witness marks" if you are a warranted car and all drivetrain warranty will be voided.
 
1 - 9 of 9 Posts
Top