Hyundai Veloster N Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hey everyone, so a while back I posted about my N having this "shake" when I drive. I was driving hard, taking a left turn, and I hit a pot hole.

I had become really set on it being speed related but now a new symptom had developed that took speed out of the equation.

When I am turning (withing a certain window of my turn) I get this metal "thunk" noise. Almost like my axle is semi-broken and skipping over because of the turning maybe?

So now the symptom list is:
Slight shake at and above 80 (feels like an unbalanced wheel, its for sure NOT though, eliminated that possibility already by balancing all 4 wheels and putting on other wheels/tires)
Metal 'clack/thunk' noise when I am turning (within certain window), almost feels like driving over a small ice patch and the tire slips, but not exactly that.

I'm thinking axle, suspension mount (read that somewhere), or Hub maybe?
I'm certainly not an expert but I got a hold on the N's repair guide and I've been reading that and talking with people and such. Doing the best I can really.

A quick visual inspection of the steering and control components shows no obvious damage (bends, breaks, tears in rubber etc.)

This is all on the passenger side.

I'm just tossing this out to see if there are any Tech's out there that know the specifics better than me. I can wrench but I just have not educated myself enough on this to diagnose yet and my dealership is playing lots of games with me.

Thanks in advance for any help!
 

·
Registered
2020 PP Veloster N in Racing Red
Joined
·
20 Posts
Hey everyone, so a while back I posted about my N having this "shake" when I drive. I was driving hard, taking a left turn, and I hit a pot hole.

I had become really set on it being speed related but now a new symptom had developed that took speed out of the equation.

When I am turning (withing a certain window of my turn) I get this metal "thunk" noise. Almost like my axle is semi-broken and skipping over because of the turning maybe?

So now the symptom list is:
Slight shake at and above 80 (feels like an unbalanced wheel, its for sure NOT though, eliminated that possibility already by balancing all 4 wheels and putting on other wheels/tires)
Metal 'clack/thunk' noise when I am turning (within certain window), almost feels like driving over a small ice patch and the tire slips, but not exactly that.

I'm thinking axle, suspension mount (read that somewhere), or Hub maybe?
I'm certainly not an expert but I got a hold on the N's repair guide and I've been reading that and talking with people and such. Doing the best I can really.

A quick visual inspection of the steering and control components shows no obvious damage (bends, breaks, tears in rubber etc.)

This is all on the passenger side.

I'm just tossing this out to see if there are any Tech's out there that know the specifics better than me. I can wrench but I just have not educated myself enough on this to diagnose yet and my dealership is playing lots of games with me.

Thanks in advance for any help!
Just from your description it makes me think it could be a bent or loose tie rod. I am by NO means an expert though, so if you already inspected and didn't see any damage I'd wait for more experienced owners to weigh in.
 

·
Registered
Joined
·
2,608 Posts
have you taken to the dealership service yet? It can be number of things from a bent lower control arm to a loose strut. If the strut is loose the spring will rotate on the spring perch and cause a thunk same with a bend lower control arm or bad CV joint. My guess is a CV joint right off the top of my head. You won't know until you've take it in for them to check.
 
1 - 3 of 3 Posts
Top