Hyundai Veloster N Forum banner
1 - 20 of 22 Posts

· Registered
2020 Veloster N PP
Joined
·
97 Posts
I have the same exact downpipe and the same exact O2 bung. My apologies for posting this here but were you ever able to get the CEL to go away completely? Mine won't and I'm okay with it for now even if I did do the extra work of pulling out the downpipe AGAIN, wrapping and spraying it, installing the same O2 bung. I still can't usually edit settings like exhaust volume until the CEL goes away by itself for a short time on certain drives. It doesn't bother me too much since I have custom mode set up the way I like it with my JB4 (maybe a different tune will not give CEL) and I regularly check OBD CEL data to make sure everything is as expected. I think I may be losing power right now even because of the CEL and messed up AFR ratios. I'm going to get to the bottom of it someday. Maybe I damaged the bottom O2 sensor when I squeezed the fat wrapped downpipe back into the car again.

Might be a warning to other users. I hear there are no headaches with the really expensive ones like SXTH but they really are stupid expensive. This a great downpipe for the price if you can live with the possibility of having a CEL.
 

· Registered
Joined
·
7 Posts
Discussion Starter · #11 ·
I have the same exact downpipe and the same exact O2 bung. My apologies for posting this here but were you ever able to get the CEL to go away completely? Mine won't and I'm okay with it for now even if I did do the extra work of pulling out the downpipe AGAIN, wrapping and spraying it, installing the same O2 bung. I still can't usually edit settings like exhaust volume until the CEL goes away by itself for a short time on certain drives. It doesn't bother me too much since I have custom mode set up the way I like it with my JB4 (maybe a different tune will not give CEL) and I regularly check OBD CEL data to make sure everything is as expected. I think I may be losing power right now even because of the CEL and messed up AFR ratios. I'm going to get to the bottom of it someday. Maybe I damaged the bottom O2 sensor when I squeezed the fat wrapped downpipe back into the car again.

Might be a warning to other users. I hear there are no headaches with the really expensive ones like SXTH but they really are stupid expensive. This a great downpipe for the price if you can live with the possibility of having a CEL.
You might be losing a bit of back pressure. For instance, stock boost is like 4 something and you’re only making around 1K. If it keeps stuttering and causing issues, you might have a HPFP issue. Happened to me…. Thank god for Hyundai warranty. Lap3 eliminates this issue but the price is up there. You also gain a bit of horsepower so if you got the money to do so, do it. But a good exhaust and a JB4 is an easy way for decent horsies and noise. Anymore questions or want to have some N buddies, message me on insta. Dennis_G156.
 

· Registered
2020 Veloster N PP
Joined
·
97 Posts
Yeah I'm sorry I didnt mean to call you out. The pipe is legit good and the price is amazing at 215 I hope you sell it. It definitely increased power and noise. Wrapping it helps reduce noise if you want that by the way. I think I may have honestly messed up the bottom O2 sensor when I reinstalled my downpipe because that O2 bung should by all accounts take care of the CEL. I am dreading removing the downpipe a 3rd time, wonder if I can just squeeze the O2 sensor out and put in a new one without damaging it.

My apologies again and best of luck selling it. GOOD PIPE I think I have personal O2 sensor issues cuz I messed with my downpipe all by myself.
 

· Registered
Joined
·
7 Posts
Discussion Starter · #13 ·
Yeah I'm sorry I didnt mean to call you out. The pipe is legit good and the price is amazing at 215 I hope you sell it. It definitely increased power and noise. Wrapping it helps reduce noise if you want that by the way. I think I may have honestly messed up the bottom O2 sensor when I reinstalled my downpipe because that O2 bung should by all accounts take care of the CEL. I am dreading removing the downpipe a 3rd time, wonder if I can just squeeze the O2 sensor out and put in a new one without damaging it.

My apologies again and best of luck selling it. GOOD PIPE I think I have personal O2 sensor issues cuz I messed with my downpipe all by myself.
Yes the guy who installed mine messed my car up a bit I believe. My bolts were hand tight… and everyone near me has never even touched a veloster N. Least the studs didn’t explode into the turbo. Yes I have someone about to bite on it. It is brand new lmao. Now I can just save to do a car wrap or something. I am not mechanically inclined and it was $500 to put on and take off. Pretty much threw away a grand. Best of luck.
 

· Registered
2020 Veloster N PP
Joined
·
97 Posts
It is not hard to do yourself if you have the time and some very basic tools. Follow SXTH's video for installing theirs, that's what I did and it was my first doing a downpipe. I'm now almost expert at it. Could probably remove and install in 4 hrs or less now and I'm no mechanic. Never changed oil before owning my 2020 VN. Just watch which tools they use where, lefty loosey righty tighty. You don't need to be a genius, it's not rocket science, it's a pipe held in there with nuts and bolts.
 

· Registered
2020 Veloster N PP
Joined
·
97 Posts
Then again I may have messed up the bottom O2 sensor trying to fit a fat wrapped pipe back in, so be very careful with that. I would remove the O2 sensor from downpipe and put it back on by hand after downpipe is in place next time. And use anti sieze on everything. Your future self or mechanic will be thankful.
 

· Registered
2020 Veloster N PP
Joined
·
97 Posts
Yes the guy who installed mine messed my car up a bit I believe. My bolts were hand tight… and everyone near me has never even touched a Veloster N. Least the studs didn’t explode into the turbo. Yes I have someone about to bite on it. It is brand new lmao. Now I can just save to do a car wrap or something. I am not mechanically inclined and it was $500 to put on and take off. Pretty much threw away a grand. Best of luck.
Oh that reminds me I did notice I was missing an exhaust bolt on the straight section of exhaust (midpipe)? That could also cause a leak in boost I bet. I have a replacement I havent installed yet because I havent been able to drive my car.
 
1 - 20 of 22 Posts
Top