Hyundai Veloster N Forum banner
1 - 20 of 120 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 ·
I have recently noticed that my VN will have a little trouble starting up in the morning. It happens maybe once or twice a month. The starter struggles for about 3 or 4 seconds before the engine fires up. I figured I should go to the forum first to see if anyone has any advice since Hyundai told me it would be $145 just to run diagnostics... No CEL, the car drives amazing; no rough idle or anything like that.
 

·
Registered
Joined
·
368 Posts
Theres a thread specifically about long start ups.
Redvn's recommendation is for misfires.
I would read up on both

https://www.velostern.com/forum/297-hyundai-veloster-n-issues-problems-complaints/811-excessively-long-startup-hot-start-2.html#post11467
 

·
Registered
Joined
·
2,649 Posts
Everything leads to the same issue. That's leak down from fuel injectors.

It's starts this way and simply gets worse over time. On top of this, FI's get carboned up quicker and don't provide a good spray pattern. Some of it, you can elevate with Chevron Techron but the leaking down FI's cause the slow starting, as the HP fuel pump needs to be reprimed. If you want to alleviate it for a while, take your foot off the clutch, press the starter twice as if to attempt to start it, leave it this way for a few seconds. Then go thru the starting procedure once again. It will generally fire off quickly.

However it's not a fix, just a band aid until the leaky FI's get bad enough to cause the car to stall and not restart. Then the Hyundai Service Department will realize the issue and replace them.

Hers' a direct link to the other thread; https://www.velostern.com/forum/297...ively-long-startup-hot-start-2.html#post11467
 

·
Registered
Joined
·
14 Posts
Hi, I got a 2020 VN with the performance package in May, about a month ago I also started to notice that my car has a rough start when is cold. I got a sound video and brought it to Hyundai. They kept my car for two days and said that they couldn’t find anything wrong. I didn’t get charge for the service. I still continue having issues and I have several recordings now. I’m planning to bring it back to Hyundai with all the recordings, funny they are a lil different sounds but u can hear the rough start, one of the sounds it’s like metal to metal. If I get any information with what is wrong I will post the results
 

·
Registered
Joined
·
289 Posts
I finally got a video of mine. It's not like yours. Just turns over for 3 seconds or so and then bogs till it starts. Gonna take it over again soon
 

·
Registered
Joined
·
14 Posts
So I took my Veloster to a second Hyundai Dealership, I played them the audios for the long stars and the metal to metal sounds too. They kept my car for 3 days and I was told the same, they couldn’t replicate the sounds and that the car started fine. Hyundai said there were no codes and no gas leaks.
I opened a case with Hyundai Corporate which I also email them some of the audios, they replied and actually someone called me and this person said they were going to follow up with the dealership to find out what exactly the dealership did to inspect the car.
Long story short I have to basically wait until the car doesn’t start for Hyundai to figure it out was wrong. This is very disappointing I have a brand new car that doesn’t act like one
 

·
Registered
Joined
·
289 Posts
I feel u. even tho mine is not the same problem exactly it's still frustrating. I was trying to upload a video but it wont let me. Is urs all the time or just occasionally? Mine seems to be once every two weeks. Sometimes once a week. And I was told the same thing at service that they couldnt replicate it so they couldnt do anything to it and it showed no codes. I left it for 2 days. I definitely feel your pain. It bugs the **** outta me
 

·
Registered
Joined
·
368 Posts
If you post the video on youtube, you can make mark it as "unlisted" which means it's only viewed by people who have a direct link, then you can copy and paste the link on a comment here and it will auto upload the video here
 

·
Registered
Joined
·
14 Posts
Mine does it almost everyday in the mornings, sometimes afternoons too. I’m really surprised that Hyundai couldn’t replicate it. Here it is a link of one of the long starts and one of the metal to metal sounds
 

·
Registered
Joined
·
289 Posts
Now every time mine does the long start it also sounds like its bogged down right after it finally gets started for a sec. I didnt hear that on yours.
 

·
Registered
Joined
·
364 Posts
They all seem related and likely it’s fuel that’s off. I only get it maybe once a month so replicating at the dealer is basically impossible. (And the starter gear grind I’ve only heard twice in 15,000 miles). I hope you guys can get some results from the dealer.
 

·
Registered
Joined
·
368 Posts
Now every time mine does the long start it also sounds like its bogged down right after it finally gets started for a sec. I didnt hear that on yours.
Yours seems like the only one not broken tbh, mine use to do this but just stopped on its own. Kinda weird. I did notice recently my stock spark plugs were not properly gapped, and i gapped them myself to 0.025 and the car noticeably started quicker. It might be something that simple, but it might also be something a bit more serious like defective fuel injectors. If you have the means to check the spark plug gap, id start there, if not, a visit to a good dealer and showing them the video might get them to fix it.
Again, mine used to do this and i wish i knew what the hell happened that it went away on its own lol
 
1 - 20 of 120 Posts
Top